PR:試験対策にクラムメディアのWeb問題集

2005年11月01日

【ちょこっとレビュー】無線LANスイッチ

2005年11月号の日経ネットワーク連載記事「スイッチネットワークの作り方」に無線LANスイッチについて書かれていたので、ちょこっとレビューします。

本当にちょこっとですあせあせ(飛び散る汗)

無線LANスイッチについては、名前だけ知っていたのですが、この連載記事によると、複数のアクセスポイント(AP)のSSID(ESSID)やチャネル、暗号化や認証などを一元管理することが可能とのこと。部門フロアのみに無線LANを数台設置するだけなら、無線LANスイッチを導入せずにAP毎に各設定を行えばよいのでしょうが、館内やビル全体を無線LANで接続しようとした場合、AP毎に各設定を行うと管理が大変です。そこで、この無線LANスイッチが登場するわけです。

無線LANスイッチとセットで使われるAPは単独で使うAPと違い、「シンAP」と呼ばれています。シンAPは、単独では動作せず、無線と有線を変換するメディアコンバータのような働きをします。

無線LANスイッチとシンAPは独自プロトコルを使って通信するので、間にLANスイッチがあっても通信が可能です。

無線LANスイッチの最も重要な機能は、ローミングがスムーズに行えることが出来るというところです。つまり、AP間の移動が通信が途切れることなく行えることが出来ます。通常、AP単独で動作する場合、移動で異なるAPへ接続する場合、移動先のAPで再認証が必要になり、ここで通信が途切れてしまうときがあります。しかし、無線LANスイッチの場合、シンAPはメディアコンバータのような役割のみをして、認証関連は無線LANスイッチ側で一元管理しているので、通信が途切れることがありません。

この機能は、無線LANのIP電話機を使う場合に有効とのことです。
もしかして、ライブドアがやろうとしている延期しまくりの公衆無線LANサービスもこの機能を使っているのかな?




posted by GETCCNA at 00:18 | Comment(4) | TrackBack(0) | 日経NETWORK

2005年10月20日

仮想端末(vty)からの接続

今回もCISCO2600シリーズを触ることが出来たので、今度は仮想端末(vty)から接続出来るように設定してみました。

Ethernet0/0のIPアドレス:192.168.1.250/24

まずは、Ethernet0/0にIPアドレスを割り当ててから、インターフェイスを有効にする

Router>ena
Password:
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface ethernet0/0
Router(config-if)#ip address 192.168.1.250 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#
00:25:19: %LINK-3-UPDOWN: Interface Ethernet0/0, changed state to up
00:25:20: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/0, changed s tate to up

Router(config-if)#



PCからpingコマンドで応答があるか確認
C:\>ping 192.168.1.250

Pinging 192.168.1.250 with 32 bytes of data:

Reply from 192.168.1.250: bytes=32 time=1ms TTL=255
Reply from 192.168.1.250: bytes=32 time=1ms TTL=255
Reply from 192.168.1.250: bytes=32 time=1ms TTL=255
Reply from 192.168.1.250: bytes=32 time=1ms TTL=255

Ping statistics for 192.168.1.250:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 1ms, Maximum = 1ms, Average = 1ms

C:\>


順番が逆だけど、show interfaceコマンドでインターフェイスの設定を確認
Router#show interface ethernet0/0
Ethernet0/0 is up, line protocol is up
Hardware is AmdP2, address is 000d.bd72.09c0 (bia 000d.bd72.09c0)
Internet address is 192.168.1.250/24
MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:03:06, output 00:00:09, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
91 packets input, 6768 bytes, 0 no buffer
Received 18 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 input packets with dribble condition detected
218 packets output, 19516 bytes, 0 underruns
0 output errors, 0 collisions, 1 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier
0 output buffer failures, 0 output buffers swapped out
Router#
物理層(Ethernet0/0)およびデータリンク層(line protocol)が有効になっている。
IPアドレス(192.168.1.250/24)も正しく設定されている。


vty(仮想端末)パスワードの設定。
vtyは0から4までの合計5つのポートを持っているが、利用者はどのポートが選ばれるのかわからないので、すべてのポートに同一のパスワードを設定する。ちなみに、vtyパスワードを設定しないとtelnet接続は拒否されます。
Router(config)#line vty 0 4
Router(config-line)#login
% Login disabled on line 66, until 'password' is set
% Login disabled on line 67, until 'password' is set
% Login disabled on line 68, until 'password' is set
% Login disabled on line 69, until 'password' is set
% Login disabled on line 70, until 'password' is set
Router(config-line)#password ccna
Router(config-line)#exit
グローバルコンフィグレーションモードから設定する。

PCのコマンドプロンプトからログインできるか確認。
C:\>telnet 192.168.1.250

User Access Verification

Password:
Router>ena
Password:
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#


最後にcopy running-config startup-configを実行し、設定内容をセーブして終了。


posted by GETCCNA at 22:43 | Comment(5) | TrackBack(0) | CCNA用語【か〜こ】

2005年10月18日

【復習】enable password/enable secret

CISCO2600の実機を触る機会があったので、復習がてらイネーブルパスワードの設定をしてみました。

CISCO2600は箱からあけた新品だったので、ハイパーターミナルの設定を行い、consoleから接続してみました。

% Please answer 'yes' or 'no'.
Would you like to enter the initial configuration dialog? [yes/no]:


初期設定しますか?ってYes or No で答えるメッセージが表示されました。
手持ちの本で調べたところ、最小限の基本設定しか設定できないみたいなので、多くの管理者は「No」を選ぶとのことでしたので、それに習い私もNoを選択。

リターンキーを押してっていうメッセージが表示されたので、指示通りリターンキー(エンターキー)押下。
Press RETURN to get started!


00:00:07: %LINK-3-UPDOWN: Interface Ethernet0/0, changed state to up
00:00:08: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/0, changed state to up
00:06:40: %LINK-5-CHANGED: Interface Ethernet0/0, changed state to administratively down
00:06:40: %LINK-5-CHANGED: Interface TokenRing0/0, changed state to administratively down
00:06:41: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/0, changed state to down
00:06:41: %LINEPROTO-5-UPDOWN: Line protocol on Interface TokenRing0/0, changedstate to down
00:06:42: %IP-5-WEBINST_KILL: Terminating DNS process
00:06:49: %SYS-5-RESTART: System restarted --
Cisco Internetwork Operating System Software
IOS (tm) C2600 Software (C2600-I-M), Version 12.2(17a), RELEASE SOFTWARE (fc1)
Copyright (c) 1986-2003 by cisco Systems, Inc.
Compiled Thu 19-Jun-03 16:35 by pwade
00:06:49: %SNMP-5-COLDSTART: SNMP agent on host Router is undergoing a cold start
Router>


うじゃうじゃとメッセージが表示され、下のほうに見慣れたプロンプトのマークが表示されたので、enableコマンドで特権モードになり、running-configを表示させてみました。
Router>enable
Router#show running-config
Building configuration...

Current configuration : 358 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router
!
!
ip subnet-zero
!
!
interface Ethernet0/0
no ip address
shutdown
half-duplex
!
interface TokenRing0/0
no ip address
shutdown
ring-speed 16
!
ip classless
ip http server
!
!
line con 0
line aux 0
line vty 0 4
!
end

Router#


特権モードからconfigure terminalコマンドにてグローバルコンフィグレーションモードに入り、イネーブルパスワードを設定。一応2種類(enable password、enable secret)を入力。
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#enable password cisco2600
Router(config)#enable secret cisco2612
Router(config)#exit
Router#


再度running^-configの内容を確認
Router#show running-config
Building configuration...

Current configuration : 431 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router
!
enable secret 5 $1$FiWD$7q3wDYR4m/pSPMmqUq4AK.
enable password cisco2600

二つのパスワードが登録されたことを確認。

enable passwordは内容が見えてしまうので、あまり使われていないそうです。enable secretはパスワードの内容をMD5というアルゴリズムで暗号化されているので、解析が困難です。

copy running-config startup-configで内容を保存し、ユーザーモードから特権モードになろうとしたところ、しっかりとパスワード要求が発生したので、enable secretで入力したパスワードで特権モードに入ることが出来ました。

久しぶりのCCNAなので、ゆっくりと再スタートしたいと思います。


posted by GETCCNA at 23:40 | Comment(0) | TrackBack(0) | CCNA用語【A,B,C,D,E】

2005年09月22日

M/M/1待ち行列の計算式

待ち行列については、詳しく書くと1冊の本になるくらいおくが深いみたいです。ここでは、情報処理の試験によく出てくるM/M/1の待ち行列モデルの計算式を書きます。理屈がわからない私は、とりあえず計算式を暗記するのみです・・・

<<記号の呼び方>>
μ(ミュー)・・・平均サービス率(単位時間当たりに処理できる平均客数)
λ(ラムダ)・・・平均到着率(単位時間当たりに到着する平均客数)
ρ(ロー)・・・窓口利用率

<<計算式>>

窓口利用率:ρ=λ÷μ

平均サービス時間:Ts=1÷μ

平均待ち時間:Tw=(ρ÷(1−ρ))×(1÷μ)

平均応答時間:Tq=Tw+Ts


とりあえず、記号の読み方がわかれば、なんとなくだけど、覚えやすいかな?

あとは、実際にこの式を使って問題を解かないと身には付きにくいですね。


posted by GETCCNA at 22:51 | Comment(4) | TrackBack(1) | 情報処理試験

2005年09月20日

リース契約について

リース契約は、法廷耐用年数に従って経費処理できる賃貸借契約であり、その物件の所有権はリース会社にある。

リース料には、固定資産税が含まれるのが一般的。

リース物件の保守や保険などの費用は、利用者が負う場合とリース料に含まれる場合がある。

リース契約を途中解約すると、多額の違約金を支払う必要があり、買い取り価格に近いものになる。


posted by GETCCNA at 23:33 | Comment(0) | TrackBack(0) | 情報処理試験

CASE(Computer Aided Software Engineering)

CASE(Computer Aided Software Engineering)は、コンピュータ支援によるソフトウェア工学を意味する。この概念井基づくソフトウェア開発ツールをCASEツールという。上流工程から下流工程までのCASEによる一連の成果物を管理するデータベースのことを、リポジトリという。

システムを構成するデータの所在を、ファイル仕様、プログラム間の関連といったメタデータを集積するディクショナリと、データベース構造に関連する情報を蓄積するディレクトリおよび成果物データベースから構成されている。


posted by GETCCNA at 23:21 | Comment(0) | TrackBack(0) | 情報処理試験

稼働率の計算方法

昔は覚えていたんだけど、年をとると忘れてしまいますね・・・

直列つなぎ
−−−[A]−[B]−−−
稼働率はA×Bで求まる

並列つなぎ
  ┌[A]┐ 
 ─┤   ├─
  └[B]┘ 
稼働率は1−(1−A)×(1−B)で求まる

基本的にこの二つの稼働率を把握しておけば、あとは応用なのでさほど難しくはないと思われる

posted by GETCCNA at 23:12 | Comment(0) | TrackBack(0) | 情報処理試験

2005年09月05日

今後の予定について

久しぶりに書き込みします(汗

CCNAの勉強をしなければいけないのですが、10月16日に予定されているテクニカルエンジニア(ネットワーク)試験があるため、今はそっちをメインに勉強しています。それが終われば再びCCNAの勉強をメインにします。

ちなみに、テクニカルエンジニア(ネットワーク)の勉強で重要だと思った事についてもアップしていきたいと思いますので、よろしくお願い致します。

posted by GETCCNA at 11:25 | Comment(1) | TrackBack(0) | 日記

2005年08月14日

ライブドアブログから移転しました

ライブドアブログのユーザーに対する対応が悪いため、seesaaブログに引っ越してきました。まだ、ライブドアのリンクになっている記事がいくつかあると思いますが、近いうちに変更いたします。

以上、よろしくお願いいたします。

posted by GETCCNA at 03:22 | Comment(0) | TrackBack(0) | その他

2005年08月05日

サーバ管理者は必読!

サーバ管理者のためのイベントログ運用の基本という書籍が発売になりました。

私のメインの仕事は汎用コンピュータやサーバの運用管理です。ログは毎日チェックはしているのですが、どこにどのようなログが記録されるのか一応は把握しているのですが、そのログを活用しているかといわれると・・・って感じです。なので、この本を読んで基本をしっかりと身に付けて、不正アクセスや情報漏えい対策に役立てたいと思います。

続きを読む

posted by GETCCNA at 09:46 | Comment(0) | TrackBack(1) | 自己啓発
×

この広告は1年以上新しい記事の投稿がないブログに表示されております。